New turningy lipo battery not charging?

Oscar BryanOscar Bryan Club Members Posts: 1

Hello,
I am quite new to the modelling hobby. I have bought a 3cell 11.1V battery as shown in the photo, a DC-4S charger and AC-DC plug which i think is rated correctly and +ive and -ve poles correct to the charger. Battery worked fine and I ran all the way down. However now I have gone to charge it and I only get three dashes, not the voltage checker (when power is not supplied) or charging (with mains power supplied). The charger has been replaced with a new one and same problem. Am I doing something wrong or is the Battery faulty?

Many Thanks! :)
-Oz

Comments

  • WTWUKWTWUK CornwallClub Members Posts: 13,610 ✭✭✭
    edited July 31

    If you ran it totally 'flat' as in below 3.0V per cell, you killed it. LiPo's must NEVER be run to anything much less than 3.0V per cell (9V total with a 3S pack) or most, if not all chargers will allow them to be recharged as the cells are damaged.

    Edit: I just googled the manual for your charger and it is indeed so you have effectively destroyed your battery - the three dashes indicate the battery cannot be detected due to undervoltage.

    You need to buy a new battery.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file