Turnigy 9xr pro and jet module

BigdomkBigdomk Club Members Posts: 4
Hi,

I can't find information anywhere about this and have spent hours searching. Switch on 9xr pro and both LEDs are steady glow on the xjt module. Switch on with bind button pressed, no blink or beep from the transmitter. Am I doing something wrong or is the xjt module duff?

I've just been given the transmitter and xjt so I don't know if It has worked properly.

Many thanks for your help.

Comments

  • WTWUKWTWUK CornwallClub Members Posts: 13,618 ✭✭✭
    Ensure the Pro is set to PPM (might be possible also to set it to PXX from memory depending on what firmware is on it).

    It is also possible that if the Pro has been flashed with the ErSky9X version that is EU LBT compliant, the XJR will have to be flashed with the LBT firmware for it too
  • SootySooty Christchurch NZClub Members Posts: 6,110 ✭✭✭
    Bind mode on TX when using XJT might be entered from model menu rather than pressing button on module. That is how I do it on my Ersky9x upgraded 9X.
  • WTWUKWTWUK CornwallClub Members Posts: 13,618 ✭✭✭
    Ahhhh yes indeed! Not used the XJT in my 9X since that was added!
  • BigdomkBigdomk Club Members Posts: 4
    Thanks Sooty and WTWUK for the quick reply.



    I've checked protocol as PPM, 8ch.

    The software on the 9xr pro is ersky9xr, boot loader V1.7, and the xjt module has been flashed with XJT_eu_150122 as I'm trying to match the controller to an frsky x8r EU release receiver and have read that the xjt module is probably international version.

    Both switches on the back of the XJT module are in the down position.



    I've looked for a bind option on all the menus but can't find one. Do you know which sub menu it should be in?



    Thank you for helping.



    Dom
  • SootySooty Christchurch NZClub Members Posts: 6,110 ✭✭✭
    It is under Model Setup - Protocol menu.

    When you set protocol to PXX further options should appear. You can set individual RX numbers and Bind and Range Check should appear at the bottom of the menu.



    My firmware is V. 218
  • WTWUKWTWUK CornwallClub Members Posts: 13,618 ✭✭✭
    Ahh your XJT has the VERY flaky EU firmware version. Strongly suggest you update your 9XR Pro to Ver.219 of ErSky9X and then use it to update the XJT and X8R to the latest EU LBT firmwares. (You can even use your Pro as a music player with the latest firmware! Heh heh!)

    Look over on the OpenRC forums HERE for all the info you could wish for.WTWUK2016-08-17 06:26:45
  • BigdomkBigdomk Club Members Posts: 4
    Thanks both, I'll give it a try and post the outcome.

    Cheers

    Dom
  • BigdomkBigdomk Club Members Posts: 4
    Hi,

    I changed the protocol to PXX and bind does appear as suggested, thank you.

    Upgraded the firmware to 219t but still cannot update the firmware on the XJT module. I've followed all the recommended steps but when I try to update the SPort the transmitter displays 'searching' and does not move on. The progress bar at the bottom does appear but there is no progress. I'm using frsky 150123.frk firmware downloaded from the frsky site. Any suggestions?

    Dom
This discussion has been closed.