Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Receiver CR8D not blinking or binding

DarkyputzDarkyputz Club Members Posts: 3
Hello!



I have this 2.4 GHZ system set for JR radios

CT8J as TX and CR8D as RX

Tried to bind them a few times as youtube, the instructions and some forum members already tried to explain...

I always get the constant blinking on the TX and I had the two blinking on the RX also a few times, but no luck by controlling something...

And now, the RX is not doing the two blinks or any blinks any more...

Is there any trick, tip or voodoo to this devices?!

The Radio I use is a JR X-388S from back than...but the package of the corona says it should work with it...

How can I trouble shoot?!



Please help...and thx in advanceDarkyputz2016-03-10 22:23:20

Comments

  • WTWUKWTWUK CornwallClub Members Posts: 13,511 ✭✭✭
    Ensure the TX is set to PPM modulation and not PCM.
  • DarkyputzDarkyputz Club Members Posts: 3
    Hello and thx for the fast reply...

    Do you have any clue how to check that on that Radio?

    I found a few manuals, but none said some details about setting to PPM

    Thx
  • WTWUKWTWUK CornwallClub Members Posts: 13,511 ✭✭✭
    Should be in the Setup>MODU menu. Not absolutely sure how to get at it, as I do not have a manual for that TX.



    However, I suspect to enter the settings menus, you press the front panel 'MODE' 'UP' and 'DOWN' buttons together and keep them pressed whilst turning the TX on.



    It will absolutely be mentioned in your manual as the 388S can be operated in either PCM or PPM modes.
  • DarkyputzDarkyputz Club Members Posts: 3
    Found it in the instructuon, but pressing them both at same time does nothing...but pressing them any time does nothing as well...



    BUT my main question here was about the rx tx combo...and how to check if one of them is broken...because re rx is not blinking...what ever i do...

    Power on with or without pressing the button...no blinking...

    Only the back of the tx...the module blinks or is steady yellow when just turned on...



    Thx

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file