Turnigy 9x v2 binds but nothing else (SOLVED)

CraigdubyahCraigdubyah Club Members Posts: 7
I have a Turnigy 9x v2 which was working normally. I performed the resistor mod to allow the trainer port to be used. Since that time, I am unable to transmit to my receiver.



The transmitter binds normally, range tests normally, but I am unable to control throttle or servos (I have tried BEC and a battery pack on my receiver). When I plug into an ESC the motor will not arm itself. I have tried the 8ch and 6ch Turnigy receivers.



I also received the FrSky transmitter module today. With FrSky receivers, it will bind successfully, but then I have no control over servos or throttle, motor will not arm. So it's not the transmitter module.



I double checked the connections on the resistor mod, even removed the resistor mod and replaced with insulated wire. The transmitter continues to work fine with the trainer port (on SmartPropoPlus).



Any thoughts?Craigdubyah2016-01-22 03:54:07

Comments

  • DaithiDaithi Belfast,IrelandClub Members Posts: 8,708 ✭✭✭
    Check the socket for the trainer lead - it's possible that it's staying in the 'open' position effectively switching off the RF side
  • CraigdubyahCraigdubyah Club Members Posts: 7
    The trainer port appears undamaged. When I plug in the trainer cable, the transmitter powers on, which makes me think that the circuit is not shorted.
  • DaithiDaithi Belfast,IrelandClub Members Posts: 8,708 ✭✭✭
    It's not a short that's the problem. When you insert a jack plug there's a small metal arm that gets pushed up to disengage the internal connection and when you remove the plug it's supposed to close again to enable the system.



    What happens is the arm gets bent up and then stays there (it's an open circuit - not a short)
  • CraigdubyahCraigdubyah Club Members Posts: 7
    Thanks, that makes perfect sense!



    Do you know a good way to straighten out the bent arm?



    Edit: or even short the circuit / disable the trainer port if needed?Craigdubyah2016-01-21 12:43:50
  • CraigdubyahCraigdubyah Club Members Posts: 7
    Update: it appears that the problem was with my soldering during the resistor mod. Somehow I connected the PPM channel to ground. I think that when I was scraping off the copper, I went too deep and somehow made a connection with a ground trace on the back of the PCB.



    I removed the solder from the trace and re-soldered a wire between the two PPM terminals. Radio works good as new!Craigdubyah2016-01-22 03:53:50
  • DaithiDaithi Belfast,IrelandClub Members Posts: 8,708 ✭✭✭
    Personally I got one of the wireless ones and a cheap 6 channel receiver (I kept tripping on the lead when the doorbell rang) image

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file