Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Servo or receiver problem????

DavjedDavjed Club Members Posts: 3
Setting up a newly built kit and having a problem with the elevator servo. Using a servo tester/centering device I centered the Tower Pro servo and attached the arm. However, on installing the servo and plugging it into Power Up elevator slot the arm swings and locks in the extreme up position. There is no way adjust the arm into a position that will correct this. Anyone had a similar experience or some suggestion to correct it and center the servo arm. Thanks for any help.

Comments

  • SootySooty Christchurch NZClub Members Posts: 6,107 ✭✭✭
    Very little info provided. Assuming it centered ok using the servo tester:



    Try the servo in another channel on the receiver - rudder or aileron. A likelihood is that your elevator servo is connected to your throttle channel. If so you can re-assign the channels & sticks at the TX or just swap around at the RX.Sooty2016-08-02 11:00:00
  • DavjedDavjed Club Members Posts: 3
    PROBLEM SOLVED. HZ suggested checking the monitor screen for excessive signal to that channel. I did so and it showed very elevated signal to that one channel. So I reset and deleted that entry in the transmitter, then re-entered it again with the same settings. No problem with it now. Thanks for the replies.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file