Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Flysky I6 and CC3D issue

SlimTSlimT Club Members Posts: 7
Hello there,



i hope that someone here can me point in the right direction.





I have a re-branded Flysky I6 transmitter - firstly used in a quadcopter called Longing LY-250.

I have bought an Eachine Racer 250 ARF as i have the transmitter and fpv monitor from the first quad-copter. Of course I bought a receiver Flysky IA6.

I flashed the CC3D original software Open Pilot to LibrePilot. Hooked it up and it works. Channel 1,2,3,4 for Roll, Pitch, Throttle and Yaw are working as they should.



Issue description:

But i cannot assign the other channels - 5 and 6 and as well the switches are not working.

In LibrePilot when i am running the transmitter set up everything besides the switches is working so i am only able to use one flight mode even tough i should be able to use the switches.

But my main issue is that i wanted to hook up for example channel 5 to a buzzer - so when i crash in high grass i can turn on the buzzer and i should be able to hopefully find it more easy.



So i can fly but i cannot use the switches which are assigned to channel 5 and 6.



Would you recommend to do a Factory reset on the FLYKSY I6 transmitter? I did not set up anything besides the FAILSAFE. Would this help? Which settings on the transmitter should i write down if they are deleted after factory reset?



Thank you for any tips or pointing me in the right direction.



Cheers

Comments

  • kevin.meyer1972kevin.meyer1972 Club Members Posts: 22
    edited March 2018

    Check that you don't have throttle hold or dual rates selected for any of the switches. I am not sure but I think that will use up one of your channels. Also check there is no mix using ch5 and 6 or the switches. I am not sure but that may also confuse librepilot.

    Sorry I not very sure, just throwing some ideas out there...

    Have you gone into the settings of your transmitter and checked what is allocated to channel 5 and 6?

    My i6 I go to "set up" and then "aux channels", choose which switch or knob I want on 5 and 6 (long press of cancel to save when I am happy).

    Then when I have my transmitter on, flight battery plugged into vehicle and cc3d plugged in to pc, librpilot pics up my switches (or pots) when I run transmitter set up wizard.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file