Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Turnigy TGY-i10 do not work with Flysky FS-iA6B rx

bryckbryck Club Members Posts: 4
Hi guys, I have a problem with this receiver after upgrade firmware.

I bought two Flysky FS-iA6B receivers and these have worked well with my tx Turnigy TGY-i10.

But every time I switched on the transmitter, on the display I have read: "a firmware update is available for your receiver". No problem, by pressing the OK button of the window, it was being canceled. To delete permanently this window, I tried to update a rx.

I have updated the firmware for only one rx. In the last page of TGY-i10 menu, "RX Setup" then "Update receiver", the tx has updated the receiver from 1.2 to 1.5 firmware version (if I remember correctly). After update, this receiver NOT WORK!

The rx does not work on channels 1-4 (all channels controlled by the two sticks) but the other channels, (ch 5 and ch 6), are working well by the knobs of tx.

Servos move only when automatic test is activated by servos display function.

But servos do not move by stick's controls!



Instead the rx without updated, work fine with the same TGY-i10 transmitter!



Could it be an incompatibility between the firmware of the TGY-i10 tx and the Flysky rx?

Is it possible the downgrade to the previous software version for the receiver?



Can anyone help me?

Thank you!

bryck2016-05-25 23:47:45

Comments

  • Paul80Paul80 Club Members Posts: 161
    Thats an odd one



    I have 6 FlySky iA6B receivers and all have had their firmware updated by my Turnigy i10 transmitter and all work fine.



    Just a thought, have you tried re binding the receiver? Might be worth a try if not.
  • bryckbryck Club Members Posts: 4
    Sure, I re bind the receiver, but on the first 4 outputs (ch 1-2-3-4) not work!

    The rx is connected to tx, the servos go exactly in the middle position when you turn on the receiver (and can not turn by hand the servo's horns, as when the rx is turned off ).

    On tx display, I read the telemetry (Voltage rx battery, Error rate etc), the red led is very bright but the rx works only with the servos on ch 5 and 6 (through the knobs or switches selected)



    I'm really sorry that for a stupid software problem, the rx is unusable now, instead before was working perfectly!

  • bryckbryck Club Members Posts: 4
    If anyone wants to see, these are the pictures of what occurs:





    image

    Software version TGY-i10 transmitter





    image

    Before update: window when I turn on tx/rx! This have not affect for the functioning and it disappears when I press OK buttom. The window returns to the next power on.





    image

    After update: the stick movement is completely irrelevant to the servo! There is a tx/rx link, detectable by the telemetry on the display and by the red led on the rx and on temperature sensor. In this case it is impossible to turn hand the servo horn, instead doable thing when rx is turned off or not connected to transmitter.





    image

    image

    The servo of the auxiliary channels (in this case the Ch 6) is controlled by a selected switch. It seems that the outputs 1-2-3-4 of this receiver are disabled after updating.





    image

    image

    What I see when I try to re update the same rx





    Unfortunately for me it is impossible to unlock this receiver...... image image
  • rhourirhouri Club Members Posts: 1
    I have the exact same problem after updating IA6B firmware using the I10.

    I have other IA6B before firmware update wthat works fine.....
  • Paul80Paul80 Club Members Posts: 161
    Ok Silly Question time



    You are pressing the little button through the hole in the bottom of the receiver to put it into update mode aren't you.
  • bryckbryck Club Members Posts: 4
    No! The update rx starts instantly when tx is into update mode, without push the button in the receiver.
  • Paul80Paul80 Club Members Posts: 161
    The button should be pushed before you tell the TX to update, so that it is already in update mode at the start of the process, not pressing the button will not update the receiver.



    And its on the top not the bottom on the i6, its on the bottom of the i10 oops
  • divebomber10divebomber10 Club Members Posts: 1
    Hi all,



    Same problem. Here's what I worked out..



    Turnigy i10 Aux channel Menu (Fixed wing 4 channel)



    CH5 - Aux1     :None (ch6 Aux2)

    CH6 - Aux2     :None (ch5 Aux1)

    CH7 - Aux3     :Rudder (Stick to be manually Assigned)(ch4)

    CH8 - Aux4     :Throttle(ch3)

    CH9 - Aux5     :Elevator(ch2)

    CH10- Aux6     :Aileron (ch1)



    Basically it mirrored the RX and TX channels So AUX 10 on the TX talks to Channel 1 on the RX. While you can re assign all the channels to get it working you lose the ability to make use of Exponential/throttle curve/control surface mixing. Pain in the butt, but you can still use everything else. (Trims/offsets/conditions)I would ulimatel like to be able to roll back the firmware though.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file