Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Severe servo jitter

CooleyCooley LouisianaClub Members Posts: 2
9X with Factory V2 module and original V2 firmware.

Servos jitter continuously and heat up.It is the same on all channels. I also have two HK 6ch receivers and they all have the same issues.



YES... modulation is set to PPM! And moving the transmitter a distance away makes no difference.



When connected to my KK2, the receiver check points are way off. Any Ideas?!

Comments

  • TheQuestorTheQuestor TXClub Members Posts: 629
    have you calibrated your sticks and pots on the 9x?
  • mick11mick11 Driffield YorksClub Members Posts: 665
    I had this,it was caused by the 5/6v SBEC giving slightly more than 6v when set to 6v.It stopped when I set the BEC to 5v.Hope that makes sense
  • SootySooty Christchurch NZClub Members Posts: 6,107 ✭✭✭
    I think you have nailed the problem. The KK2 hates anything over 6v. I get the best response at 5v.
  • WTWUKWTWUK CornwallClub Members Posts: 12,851 ✭✭✭
    What servos are they, and how are you powering them?



    Some servos will absolutely not tolerate 6V. Classic symptoms are the jitters or very jerky movements, followed by heating up and then death of the servo. I mistakenly connected up a 6V BEC to an RX and servo the other day, forgetting it was a 4.8V only capable servo. It died within two minutes.



    As is also said here, 6.0V is not good for KK controllers. You really do need to run them at no more than 5.5V and 4.8V is fine for them.

  • CooleyCooley LouisianaClub Members Posts: 2
    Thanks fella's. But I don't think it's a voltage issue because I've tried several different ESC to power the receivers. I get the same results with each. I will check the voltage on the bec just to be sure, but they are supposed to be 5v.



    I'm wondering if this could be a problem with the Tx Module. Could it be causing such issues?Cooley2016-01-27 22:56:01
  • SootySooty Christchurch NZClub Members Posts: 6,107 ✭✭✭
    I made the mistake of buying 4 Corona HV Servos which jitter and chatter just cause they want to. Absolutely useless unless I run them at around 4.8v or 5v and even then they are all over the place.



    Haven't come across a model with enough constantly flapping parts to use them on yet. image
  • flyguychriswflyguychrisw Richmond, VAClub Members Posts: 1
    hey guys im starting a build with a hk 500 i bought off of ebay.the servos that are in it dont fit properly (hitec hs225bb mightymini)i am new at this but i can see this is all wrong! can anyone tell me the right ones for this app.im trying to use all align parts if possible
  • WTWUKWTWUK CornwallClub Members Posts: 12,851 ✭✭✭
    Align DS525M.
  • KaosKaneKaosKane Club Members Posts: 1,848 ✭✭✭
    switch away from pwm in first options page

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file